Overall issue with Blocs 3.3, unable to use funtions

I just downloaded the 3.3 trail to try out Blocs, and notice that I can’t use the Asset manager. Here’s ascreenshot of how it looks

Can’t search, can’t see any files or pictures. When I’m adding an image, it doesn’t show up. When I’m trying to add it again it says it’s already in my library. Can’t use the text window to search. And the text is kind of above the search window. It’s the same with the other Manager windows. I’m using MacOS Sierra 10.12.6.

Welcome to the Blocs forum. Here are a couple YouTubes you might find useful.

If you take the following steps you should see the image below.

Start Blocs
Click on start new project.
Click on asset manager…

You might try rebooting you machine.

Yes, that’s what I thought too, and that’s what I’ve already tried. Reboot doesn’t solve anything. Still looks like the screenshot I posted above.

Have you tried to remove Blocs and re-instaIl?

Also, maybe some issue with version of macOS I don’t have a machine running Sierra to test… so, do not know if your problem is related to macOS version? What is stopping you from upgrading to High Sierra or Mojave?

I’m using an old MacBook Pro 13" mid 2010, I guess I could upgrade to High Sierra though.

Just a guess about the version of macOS might help but High Sierra might be better anyway.

However, It should work on Sierra . The FAQ has the following:

Yes, thanks for your input eagle. Anyone has other ideas?

I used the Blocs 3.3 trial on an old Mac laptop running 10.11.6 (El Capitan) and then opened up one of Eldar’s templates (which I had previously purchased) and it worked normally showing images in the Asset Manager window. I then added a new image to the Asset Manager without any problems.

Might help to start over with a new project and have an images folder next to your .bloc file with all the needed images before trying to add them with the Asset Manager. That’s what Eldar does for all his templates. If drag and drop doesn’t work, try using + icon in top right of Asset Manager window to add new images from images folder.

Hope this helps. Good Luck.


This is the most important part to make Blocs work with images as it should.

The app doesn’t look like it’s installed correctly. Is this a case sensitive HD?

What did you use to expand the zip file? It looks like the app is corrupt

Yes, it’s a case sensitive HD, is that the issue perhaps? Is there any way to install it to make it work on a case sensitive fs? I just expanded the zip as usual with apples native unzipper, and that’s never been a problem before.

Here a major problem for with Blocs 3.x!
When I search a Bric, any element, Blocs 3 freezes. I have to close down Blocs every time. It’s been doing this since every version 3. I always half to stroll through the selection to find what I need. I’ve removed all Blocs Apps. Cleaned anything left behind with App that clean any traces left behind. Reinstalled and still can’t get rid of the problem.
@Norm has informed me the problem is limited to EL Cap. Warning if you don’t upgrade your OS you will have issues!
I have a disabled son, so can’t afford to purchase a new Mac yet. I’m at the highest version I can go on my MacBook Pro.
You can see in the Blocs 3 will not allow me to type or choose… :unamused:
Am I the only one who is experiencing this?

hey, unfortunately Blocs does not support case sensitive HD’s. It’s covered in the system requirement FAQ.

unfortunately Blocs V3 no longer supports El Capitan, I would recommend trying some older versions of Blocs V3 from the archive (scroll down to bottom to get 3.0.0), some older versions may still work but will obviously lack new features.