Preview issue - Wont Work in BLOCS 3

Hi all, my new Blocs 3 program wont show a preview in any browser or mode? all i get is:

Internal Cardo Updater error

any ideas how this can be sorted?

Im working on this, Did you try changing the preview ports in prefs.

basically Blocs is struggling to set up a local server, anything that prevents access to port 8080 will cause issues.

I hope that helps, more info and fix on route.

I had the same problem on my iMac. I have no idea why port 8080 should have no access. My work-around is setting the preview Type from “local server” to “file preview” in Preferences. Now i see a preview.
Is there anything i miss or are there some preview-funktions not avaliable in “file preview”?

I’m also having a problem of previews right now, but only with one bric on existing projects. I am not able to export the project to a local folder either.

screenshot_1322

Strangely, it works if I use the bric on a brand new project.

Is this Bric one of ours?

No it’s the map bric.

It’s the OSM Bric by blocs-extension.com.
Same happens here.
I’ve sent an e-mail to the developer.

This site can’t be reached

blocs-extension.com ’s server IP address could not be found.

I couldn’t reach it either, but it worked when I went there via the Blocs store and clicked on the developer site link: https://blocs.store/product/osm-map/

@Bootsie I couldn’t export the site to a local folder either when the bric was in place. No doubt something that will be fixed soon though.

Exactly. That’s the website.
blocs-extension.com” is just the name of the developer and not a link.
Sorry for the confusion.

Try resetting the Bric. Right click reset.

No change, it’s still the same. It refuses to preview and if I try exporting the site to a local folder it fails to do so properly.

Is it free I’ll download and see what the cause is.

Yes it’s the map on the store https://blocs.store/product/osm-map/

The strange thing is that if I open a completely fresh project it seems to be OK, but I’ve tried adding it to half a dozen existing projects and they all have the same issue.

Hello,

you are missing the “s” at the end of blocs-extensions.com Do I wrote it somewhere without “s”?

I think I found the source of the problem and will look with @norm how to resolve it. I will publish an update in the next days and will let you know here.

For those having the problem, can you please try this version and let me know, if it works for you? (The custom icon is not working in this version)
OSM_Map-1.1.1-test.bex (96.9 KB)

You have to delete the installed version first, then restarting Blocs, then installing this test version and the restarting Blocs once again.

Sorry for the inconvenience.

I want to download it, but I keep hitting the SSL error. Neither Safari nor Brave will let me access the file at the moment. These constant SSL issues on the forum are getting really silly.

The forum can’t make up it’s mind if it’s forum.blocsapp.com or blocsforum.discoursehosting.net

1 Like

@webplus OK I got there in the end and yes this does seem to solve the preview issue.

2 Likes

Same here.
All fine.

2 Likes