Problem with CSS πŸ†˜

Hello guys! After working and working and asking for help repeatedly in the forum (THANK YOU EVERYONE WHO HELPED ME @Malachiman you are the man!) I almost have my site running completely with the implementation of the php code. At the moment I have some errors with the css and its causing a problem in the way that safari visualises my search engine, it modifies it completely.

If any expert could help me?

I have no idea what the error means because I have already redirected the path to the css and style in the index.

The problems are:

(index):12 GET http://www.volfly.net/css/animate.min.css?6258 net::ERR_NAME_NOT_RESOLVED

(index):13 GET http://www.volfly.net/css/font-awesome.min.css net::ERR_NAME_NOT_RESOLVED

(index):14 GET http://www.volfly.net/css/ionicons.min.css net::ERR_NAME_NOT_RESOLVED

Also there are some warnings

2DevTools failed to parse SourceMap: http://volfly.net/assets/css/style.css.map
(index):1 A cookie associated with a cross-site resource at http://protesidenext.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.

I appreciate any kind of help! Thank you so much in advance!!

He stewie,
it says http://www.volfly.net.com why the .com is there?
you site is http://www.volfly.net
consider https certificate by the way.

1 Like

For a site like this I would think SSL is a minimum under GDPR. Apart from any legal requirements it would really hurt sales if the website is not seen as being secure.

1 Like

There is an SSL certificate but only works if i place an s to the http dunno why doesn’t go directly ! Do you think this is what is causing the issue?

when I place the https on front it gets even more errors https://www.volfly.net

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.woff2?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.woff?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.ttf?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.svg?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.woff2?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.woff?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.ttf?v=merlinx_1.5.

[Warning] [blocked] The page at https://www.volfly.net/ was not allowed to display insecure content from http://www.volfly.net/RWD/assets/fonts/awesome/MerlinXFontAwesome.svg?v=merlinx_1.5.

[Warning] The page at https://www.volfly.net/ was allowed to display insecure content from http://www.volfly.net/RWD/captcha/?0996014722718688. (d6835abb_errorlog,jquery,_la,jqgrid,mgrid,qtip,mgrid_sbox,valid,cal,sbox,smap,jcarousel,mbasecal,mtp,masgg,mmultisel,loadscripts,mtrans,sel2,slider,bootstrap,main,qs,qtipinfomsg,welcomepopup,tcal,toe,dstpicker,sdynmap,experts,mcal,mscal,jqmcal,jqmtp,jqmasgg,jqmmultisel,airpmap,rmap,vellipsis,curr,offices,lang,basket,offrenderer,cart,jscrollpane,locmap,resize,jqlazyload,jqparallax,webworker.js, line 2, x5)

You would need a 301 redirect inside the htaccess that forces everything to the secure address. There are lots of different ways to do this. In my case I always go to https:// as use a particular solution, but it looks like you are going to https://www so you will need something like this https://htaccessbook.com/htaccess-redirect-https-www/

If I go to your website at https://www.volfly.net it shows as not being secure. You are linking to various insecure content, such as font awesome assets, which is clear from the web developer tools in Safari if you check for errors.

In project settings are you listing the address as http://www? That could cause this and I always leave the address empty in project settings. For SSL to work properly everything must point to secure content.

Im doing it like this! not sure if its correct!

<link rel="stylesheet" type="text/css" href="https://www.volfly.net/css/bootstrap.min.css">
	<link rel="stylesheet" type="text/css" href="https://www.volfly.net/css/style.css">
	<link rel="stylesheet" type="text/css" href="https://www.volfly.net/css/animate.min.css">
	<link rel="stylesheet" type="text/css" href="https://www.volfly.net/css/font-awesome.min.css">
	<link rel="stylesheet" type="text/css" href="https://www.volfly.net/css/ionicons.min.css">

I will get a new hosting for this site cause I think 1and1 is having some conflicts

also those RWD assets are from MerlinX, is what the php code ads but looks its works good here https://www.lostonyouagency.com

That’s not right with an SSL site. It should be https://www in your case or you can leave it blank and then rely on the htaccess redirect, which is what I do. By leaving it blank I am also able to test on other domains without problems.

So I should leave it like this? <link rel="stylesheet" type="text/css" href="/css/bootstrap.min.css">
and then edit the .htaccess file?

I am talking about the project settings in Blocs where you type in the url. Leave that blank and export the site normally, then use a 301 redirect to https://www. Incidentally that other site does not have a 301 redirect, which is really bad.

is in blank

It should look like this right?

getting this now https://www.www.volfly.net

Inside Blocs looks correct. I’ve never used that htaccess redirect and it was something I simply Googled, so we have to assume it is correct at the moment.

β€œwww.www.volfly.net’s server IP address could not be found.”

Something is obviously wrong in your setup somewhere. You could try searching Google for a different 301 redirect solution to see if that works.

N.B See the notes on that page about ending up with www.www

If you’re seeing the double www, you will need to hard-code the literal name of your domain in the RewriteRule of the above technique. So change this line:

RewriteRule (.*) https://www.%1/$1 [R=301,L]
..to this:

RewriteRule (.*) https://www.example.com/$1 [R=301,L]

That last line needs to include the full url. Read the web link for that redirect.

I will try to upload it to a different host! this one works good right? https://www.lostonyouagency.com is the same project just a different domain but it doesn’t give me those errors

So here is the problem. I have 2 version of Bootstrap in my page. Bootstrap 4 and bootstrap 3.x The first highlighted CSS has Bootstrap version 4. Second highlight has Bootstrap 3x inside it along with other styles.

This looks like a conflict between both versions and my styles. Any idea of how to fix it?