Problem with iPad view

I have designed my website with a double navigation bar, one designed for desktop view and another for tablet and phone.

I have the following issue that I cannot solve.

I have properly toggled the visibility of each of the two navigations bar. In the first one I have left active only desktop, in the second one just tablet and phone.

The issue is that my iPad (quote old Ipad air 1) keeps on showing me the desktop version also on iPad and I cannot find a solution.

I am in Blocs 2.6.5.

Can anyone please help?

Hi Dan

This may be the answer but without knowing the link for your site I can’t test it.

Part of recent versions of iOS is a setting in Safari to “force” the desktop version of a website. If you are using iOS13 the there is an AA (Big A / Little A) on the left of the url bar at the top. If you press this you can toggle between desktop and iPad default views.

It may be that your iPad is forcing the desktop view and therefore showing the wrong version of your menu.

Just a thought. Hope it helps


Thanks for advising.

This is what I also thought but even if I force the native iPad view, the site is showing the desktop version.

This is the visibility setting for desktop view:
Schermata 2020-04-23 alle 10.48.53

This is the visibility setting for iPad view:
Schermata 2020-04-23 alle 10.48.59

What am I doing wrong? Please help! Thanks,

So the question is:

Is iPad considered as a tablet as far as visibility in Blocs is concerned? Please advise.


It’s based on screen size not device. if the iPad has a screen that fits the measurements of a desktop it will show the desktop.

Hi @Norm could you specify the unit of measure you use for the screen size ?


Bottom left corner of the design canvas. It changes with breakpoint.

Screenshot 2020-04-23 at 17.14.37

Hi @Norm

px that is. So you’re actually talking about screen resolution, correct ?


Pixel width is what bootstrap bases it’s breakpoints on.

Thanks, clear.
My problem is overlapping in the navigation bar of the site name (written instead of the logo) with the menu items, when viewing from iPad.


How could I solve this?

can anyone please help to solve this issue?

I had exactly the same problem. I just reduced the type sizes until it worked!

Yes, clear but it becomes smaller also on bigger displays.

Is there a way to make it automatically reduce basing on the display size?

Please advise.

Yes, In the class manager (I think it’s called, I’m not in front of the computer at the moment), you can set logo type sizes and Nav bar link sizes for each breakpoint.

Hi, just to clarify what I said yesterday. It’s in the project settings (under File), go to the T symbol, choose Object and scroll down to find the Navigation Links and Logo Text, where they can be changed for all different breakpoints.
Hope that helps.

1 Like