Problems with local Web fonts in Blocs

@Norm
Having problem with local web font, I´m using both google Open Sans and local installed font BebasNeue and have problem to get it to work, I have spent 5 h on this topic now and I´m a little bit frustrated now. Doesen´t work on any unit. I have installed the BebasNeue as an local font with .ttf , .eot, .svg, .woff, and .woff2 but still not working.
Blocs doesent generate any .css file for the Font, unless in style.css where I find this string= @font-face {font-family:‘BebasNeueBold’;src: url(’(null)’);src: url(’(null)’) format(‘truetype’);font-weight: normal;font-style: normal;}

Whats the problem ? Somebody who have some time to check it.
I have done som screenshots of the web-folder which I have uploaded to the server, several times, and erased and uploaded.
Sk%C3%A4rmavbild%201Sk%C3%A4rmavbild%203

AFAIK The font files are loaded into style.css. I did a quick check loading a working font.woff file into the font manager, the fonts was applied correctly and I can see the @fontface in the style.css.

Try a different, know to be working .woff file.

(using v2.60)

I’ve fixed a few issues with Woff2 files ready for version 2.6.1. I’ll try installing this font and see if I can replicate the issue. Were was the font stored when you installed it? USB, Dropbox, local drive?

@Norm The files are stored locally on my disc. But the problem was that I have to create my own css-doc @font-face {
font-family: ‘Bebas-Neue’;
src:url(‘Bebas-Neue.ttf.woff’) format(‘woff’),
url(‘Bebas-Neue.ttf.svg#Bebas-Neue’) format(‘svg’),
url(‘Bebas-Neue.ttf.eot’),
url(‘Bebas-Neue.ttf.eot?#iefix’) format(‘embedded-opentype’);
font-weight: normal;
font-style: normal;
}

And then I load it together with the fonts in the Preferences install: local web-fonts then it worked, then your stylesheet got the right URL for the FONTS like this:
background:#FFFFFF url(“img/pageload-spinner.gif”) no-repeat center center;}@font-face {font-family:‘BebasNeue’;src: url(’./fonts/BebasNeue/Bebas-Neue.ttf.woff’);src: url(’./fonts/BebasNeue/Bebas-Neue.ttf.woff’) format(‘woff’),url(’./fonts/BebasNeue/Bebas-Neue.ttf.eot?#iefix’) format(‘embedded-opentype’),url(’./fonts/BebasNeue/Bebas-Neue.ttf.svg#BebasNeue’) format(‘svg’);font-weight: normal;font-style: normal;}

Problem is solved

Thanks for all help

visit https://www.gup.se to see the result of BebasNeue

Cheers Lars

1 Like