Safari-Vimeo video not displaying


#1

Hello, I’m having issues with a video playing on Safari only. I tested Chrome, Opera and Firefox.
It seems that it’s only the first video in the lineup that is affected. I reviewd the embed settings as well as the assigned names to the individual parts of the bloc. Cannot figure it out.
Link in question.
http://itbeis.com/work.html
Any advice or suggestions would be welcomed.
My OS is: 10.13.5 High Sierra.
Safari Version 11.1.1 (13605.2.8)
Thanks


#2

Hi @pkeenan

For me the two first videos won’t play in Safari.
Check your settings on Vimeo.
It looks like there’s some domain restriction on all the videos.
Which doesn’t make sense since the other videos do play and also has that restriction.
But it could be worth checking out.

Cheers / Johny


#3

Thanks for checking on this Johny. I released the imbed code to anyone and the Mercedes spot at least plays from the site. I had no issues with the 2nd spot but I released that one as well after your reply.
This is all very strange. I accessed the site via my iPhone and I had the same thing happen in both Safari and Chrome. In the Safari browser of the iPhone, the 1st video showed the “Sorry” warning, in Chrome it played.
Not sure if this is a Blocs problem or Vimeo?? As you mentioned, the rest of the videos are not having any issues and all have the same settings.
Any other suggestions?
Thanks again!


#4

Hello again @pkeenan

I see you got it working now!
What was the solution?

Cheers / Johny


#5

Well, I had to give up the right for anyone to embed the code which I would rather not do. See screenshots.

I’ve put in a request with Vimeo and just now downloaded the Blocs update 2.6.2 with the hopes that maybe something between the two will surface with a fix.

Again, all the other videos work fine except these two. I cannot figure out the difference between them and the other files.

Thanks!


#6

I thought it was something like that.

It could be that your domain only is http.
And that embedded Vimeo videos which always are https causes that strange issue.

Does your web hotel have “Let’s Encrypt”?
If so turn it on for your domain.
Browsers now complains that your page isn’t secure.


#7

My site is https already so it can’t be that. It’s through GoDaddy, Not sure what you mean regarding "Does your web hotel have “Let’s Encrypt”? Are you speaking of whoever Hosts my site?


#8

Yes, most web hosts offer free https through “Let’s Encrypt”.
Your link in your first post goes to a http site.
The “itbeis.com” defaults to http, unless you actually type https://

If you have ftp access to your domain root files you should add function to force https in your .htacess file.
So every visitor regardless only get the https site :+1:


#9

Got it. Vimeo deletes the https from their link. It’s there if you go to the site you will see it in the URL so I don’t think that’s the issue. Vimeo got back to me and they are investigating. Stay tuned and thanks!