Site Pages Stopped Working After Changing Directed Home Page

Hello, I’m using Blocs 3.5 and needed to change the home page to a different page already on the site. I did not site modifications. I exported the file with the ‘Clean URL’ box checked. The file was uploaded to Godaddy file manager which I have used for a year or two with this site with no issues. Now all pages show up with 404 errors except the main page which has no extension. All the pages have a clean URL, e.g. blulaboratories.com/about/. When I go into the search bar and change the URL to About - Blu Laboratories, the page comes up. I prefer to have clean URLs but if making the site work requires the .html, I’m fine with it. I’ve tried uploading the pages both with clean and regular URLs and the site still always directs to a clean URL which gives the 404 error. Is there a known issue I’m not aware of?

Thanks!

Remove all files on your hosting provider’s server and re-upload.

2 Likes

Thanks I’ll give that a shot. I have one other strange thing that’s making that more difficult. I recently got a new MacBook Air with the M2. Now when I export my project all the html page files are saved as a folder containing a file ‘index.html’. On my old computer they saved properly as just html files with the page name. Any idea what could cause this? I can’t find a setting to change. See screenshot. Thanks!

I think that’s because you have Clean URL checked, (but someone more knowledgeable will probably correct me!)

1 Like

I think, as @Bloccali says, it’s the clean URL option. I use it all of the time with VOLT CMS. It doesn’t seem to cause any problems as Blocs knows what it’s doing.

Just uncheck it in the project setup popup box and re-export - should do the trick.

1 Like

Yes it’s how clean URLs work.