Solved - Missing assets with Catalina

Just updated to Catalina and Blocs 3.4.0.

Now, all my assets are missing, yet Blocs knows where they are. (Show in Finder.)

Is there a simple solution?

Where are the assets hosted?

I’m readying a bunch of problems with Catalina that may be OS permission related.

The simple solution is to copy your project and then run the bulk embed asset function on the copied project. That should fix it.

Hi, in a folder on my laptop.

I just updated my website two days ago under Mojave, everything was fine.

Now the Assets window shows a load of placeholders, but if I select Reveal in Finder Blocs knows exactly where they all are.

So prior to embedding, which I will do, is there an easy way to relink the assets to my Blocs project?

(I assume embedding assets duplicates rather than moves them?)


P.S. I meant to add I’ve tried dragging the assets from Finder, but the Assets window keeps disappearing!

Oh, just discovered that when the Assets window is set to “Project Assets” it also shows Patterns etc until another dropdown is selected, and then go back to Project Assets and it’s as it should be.

Are you getting the missing assets window?

If no, it means the resources are being restricted and blocked from rendering but still exist in the document.

It could be that Blocs has been quarantined by Catalina on your system so check that gatekeeper hasnt limited its access.

You could also try directory downloading 3.4 and running it with your project.

Good call Norm, just ticked the box and hey presto.

I’m guessing this will do the trick for a great many people!

1 Like

This is the Project Assets window glitch, showing other stuff too…

That’s good to know. I wonder why it got restricted.

I’m reading about a wave of issues developers are having with Catalina.

I’m going to write a knowledge base post on this tomorrow.

Are you using the public build of Catalina?

Yes, 10.15

1 Like