Thumbnails have disappeared from Assets & Carousel

The thumbnails in assets have suddenly disappeared upon uploading 4 new images into assets. All the thumbnails are gone except ones left over (that I did not delete) from the default images that came with the app.

In conjunction with this the photos have disappeared from Carousels and have inconsistently disappeared from some but not all of the pages icons on the left of the interface. While the Carousel indicates “EMPTY CONTAINER” the thumbnails can be seen under Appearance where slides are managed (on the right of the interface). Additionally the photos appear properly in Preview Mode and when a page previewed in browser (Safari).

I’ve tried without success to try and fix this issue by re-starting the app and rebooting the computer.

Previously saved versions of this Bloc document (I save and sequentially number edits every once in a while) do not have this problem.

I also see that groups that I had created seem to have disappeared during one of my saves.

While it appears I can still continue working on my present Blocs document, it is frustrating that the thumbnails and photographs have disappeared and some of the WYSIWYG functionality has been lost.

I’m running the latest version Blocs 3.2.4 and Mac OS 10.13.6

This would appear to be a bug of some sort. Best as I can tell. I’ve also sent the same question to support but have not had a reply in 2+ days.

I have the same problem. I just downloaded the updated version of the software that was released today and it made no difference. The images are completely missing from my carousel but are showing on the website, however ALL my images are missing from the assets except the original ones which came with the software.

Another issue, likely associated with the same problem. When the project settings are set/reset it opens a pop up “project thumbnails are being updated, please wait.” which then freezes everything.


I’m getting a little annoyed.

The issue is now further complicated not only with SOME assets appearing in the Assets Manager and others appearing in name only, but both appearing when previewed in the browser. The ‘text only’ invisible images in the Assets Manager also don’t appear on the editing pages. Moreover I can’t access any of the ‘text only’ images when/if I create a new image on a new page.

What is going on?!

More attempts to solve this problem on my own. I think I found a solution.

  1. It seems that Blocs will only properly manage Assets if the Blocs App and the Blocs website file and the original assets folder are ON THE SAME DRIVE.

  2. It seems that if Assets are being fed from two different folders on two different drives (in this case with the same name and contents) it will properly manage only those image files/original assets that are on the same drive as the Blocs app.

  3. The assets that have files on both the first drive (non-App drive) and a second drive (App drive) can be made to work properly if one moves the image file/original assets folder on the first drive to another location on that drive. Then Blocs seems to find the original files on the App drive and works properly.

See details below:

The original issue occurred while working on my MacPro desktop with multiple internal drives. The website files (Bloc and assets) were together on one drive (Work) while the Blocs app is installed and runs on another internal drive (Apps). Things worked properly for a while and then the asset thumbnail disappeared (as outlined in my original post).

To continue working on this website while travelling I copied the website files to my (Work-laptop) drive on my laptop. After several days of work on the website the Blocs app began behaving erratically including several crashes. To duplicate the website files (and prevent any loss of work) I copied the Bloc website file and original assets/image folder to my “Documents” folder on my second laptop drive (Apps-laptop). Here, magically, Blocs began to work properly for any new uploads to Assets (i.e. showing the thumbnails in assets and with the image icons on pages being populated by actual image). However, ‘text-only’ images DID NOT appear.

Within Assets Manager I checked the location of the ‘text only’ assets and found these were still with original assets/images folder on the Work-laptop folder. I then checked the location of assets properly showing their thumbnails and found these in the original assets/image folder on the Apps-laptop (in Documents)

This suggests some bug or other issue where Blocs is unable to consistently access and display images if these are on a different drive than the app.

I then tried to “Refresh” a ‘text-only’ asset but this did nothing. the image does not appear in asset manager. Nor does it appear on its page. It does, however, appear in preview.

Then I tried deleting an image file from assets to see it would give me the error message outlined in “MISSING ASSETS” in Bloc’s troubleshooting instructions. This did not work. The file simply disappeared from Asset Manager AND the page and I was not given the query box for finding a missing asset as outlined in the instructions.

Finally I moved the image file folder on Work-laptop drive to another location on that drive and for the first time the thumbnails appeared for those previously ‘text-only’ assets. Checking “Show in Finder” for these assets and they are now linked to the folder/files of the same name on the laptop-Apps drive.

Grrrrr! What a waste of time. I’ve used Freeway previously and it did not have these issues. Moreover other image apps like Lightroom or Capture One allow files to be stored on separate drives and if links are lost it provides an error message and provides a way to find the missing files.

If my conclusions are correct, there clearly needs to be be some work done by the Bloc’s developers to allow paths to assets between drives AND in the meantime some clear instructions should be provided directing users to keep the App, website file and assets on the same drive.