Trickle Down Button Padding in all States

I’m not sure if its just me, or how Blocs is made, but I would love to be able to set the padding on a button and NOT have to then set the padding on all other states. If I set the padding to 15px it should trickle down to Hover, Active, Focus, Visited etc. so I don’t then have to go change the padding on all of those unless I want the button to look different in one of those states. I waste a lot of time adding the same settings for buttons.

It works fine for background, border, typography, etc. but never for padding :no_mouth:

1 Like

I think this is how it works now, unless you are styling the unstyled button. I usually start with flat or clean, and the padding I set for one state applies to all other states automatically.

1 Like

That must be the problem. I always set the default button to unstyled. I will try using flat and see if it helps.