Unable to upload using FTP

Computer: iMac Pro i7 (2017)
Software: Blocs v5.0.8 (paid for)
OS: MacOS Ventura (13.3.1)
Hub: BT Smarthub2, connected using wi-fi: download 36·9 Mbps, upload 6·7 Mbps

Following a productive chat and assistance from Fasthosts on Friday, I was still unable to actually upload my website. The second person I spoke to at Fasthosts made some adjustments and advised it could take a couple of hours for the changes to propagate. I waited (actually 3 hours) but the website would still not upload.

I have returned to uploading this evening with the same disappointing result. I have successfully exported the website to my computer as html, and it loads into Safari with no issues.

The ‘path’ to the top level of the domain (http://ambb-test.co.uk) works when entered directly into Safari (or Edge, or Firefox), and returns a 403 ‘Forbidden’ response if I use the subdomain path (http://ambb-test.co.uk/severnvale).

Here is the appropriate screenshot:


Any Suggestions? Blocs seems to be working perfectly as far as I can ascertain.

When I go to “http://ambb-test.co.uk” I get this:
“Great news – your Web Hosting package is ready to use!”
And most important - this:
Important: Make sure you upload your files to the htdocs directory

Some hosts don’t require a path for FTP and will go directly there. I think when I skimmed the fasthosts docs their FTP accounts do not need the path.

Was just a thought.

1 Like

Many thanks. I was trying to do that, but Fasthosts were not clear as to how to format the path. The answer is: Path = “/htdocs/”. Similarly, for a subdomain, the path is “/htdocs/subdomainname/”. Easy when you know how, of course.

That’s what I meant.
Glad you solved it.