Unwanted double animation

Hi,

I am having double animations on some pages on the logo of the website, we just want the animation 1 time.

Here is an example

http://aatconsultingec.com/new/

How can we fix this, please?

Thanks

any new on this please we keep having strange repeated animations

http://www.aatconsultingec.com/

Thanks!

Have you applied an animation to both the brick and block?

Hi, we only applied the animation on the brick!

I’m not sure what the problem is. We have the same problem on our site. But i know that i have included some new js files. Maybe there is a conflict in the jquery js. Not sure.

Same behaviour as by you

The odd thing is on both these examples, I only see a partial animation folllowed by the full animation. Then when refreshing the page I only see the one animation.

Cant get to my Mac, so this is on an iPad Pro.

Have you tried changing the animation type to something different and then back again, not sure if it will work but very easily tested.

Also does this happen in a local copy, or just in the server hosted version?

This is caused by the fact that when the browser loads your content for the first time it reads it twice, it’s utterly irritating if you have animation in your header area, I’m not sure why the browser does that but it’s a known issue. The way to prevent it is to use the pre-loader found in the site settings (click window title).

1 Like

On local copy is everything fine. It just happen online. And i agree with @Norm. It can be issue with the loading in browser. It can be issue with the size of the object (loading object), We have used preloader before and i think we had not that issue. Need to test it with preloader again.

Thanks for your answer.
R.

1 Like

I find it tends to happen more if you have videos embeded or used on the page. Its something todo with how the site is first loaded, its not only Blocs sites that are effected, Ive seen it talk about around the web a few times.

Because we had some updates on the page. I have updated the preloading again on page. And there is no more double animation :smiley:

3 Likes

Hi Norm I can confirm that the double animation is gone when using the preloader. Its great thanks!

2 Likes

@norm I have a loader and still loads twice what to do I have no video on the site.

https://mer54715.datafeedfile.com/ezlink_bookmarklet/howto/

Firefox, Chrome is fine its Safari thats the issue. Its Annoying most our users are macs and use Safari.

Hi Norm – Glad to find this post, as I sent you a ‘bug’ report after no response to my forum post on the same issue about a month ago.

I have always and still am using the pre-loader (gears) and the issue persists in the header area, using a simple H3 text animation, using a specific speed and delay settings. It appears to be limited to Safari at the moment. www.danielfactor.com

Any other suggestions to resolve this?

Hi @DanielF,

I hadn’t noticed this issue on my web site animations before since they are lower down on my page, but I think I have this problem too. I have the pre-loader enabled.

I tried changing some attributes on my animations to see if it made any difference. If I set the animation delay to 1 second, that seems to bypass or mask the problem. Maybe you could try that too to see if makes a difference with your animations.

I’m not sure I like having a 1 second delay. I may revert back to using the Scroll FX feature for my graphics instead.

Hope this helps. Good Luck!

Paul

Thank you, Paul, so much for the ‘1 second delay’ suggestion.

Right now I have it set for .4 sec delay, and I think that a longer delay is too much time, as the user may move on and miss the reveal of the content.

Scroll FX is an option, but I’m not a big fan of it for my site/content. I find it does work for certain sites that benefit from the visual effect, where it compliments the user experience, but in my situation it feel it would create a visual disorientation, and so detract from the content.

I do appreciate your response, though, and kind attention to the issue! :pray:

Yes, I understand your concern about not using the 1 second delay on animations. I have the same concern.

I was looking through some earlier posts and found this.

I’m not seeing the preloader being invoked every time on Safari for both your web site and mine. I do see it being invoked every time on Firefox and Chrome. As identified in the post, if the preloader is still not available (even though checked) on Blocs for Safari and the preloader helps Firefox and Chrome eliminate the double animation effect (similar to having the 1 second delay I used on my animations), could that explain what we’re seeing?

If true, not sure what to do about it. :frowning:

Thx.

Paul

Thanks for your efforts, and sharing the post…it appears to provide the only workable
answer: Pre-Loader Bug?

:pray:

…as a follow up, I followed Norm’s fix, and it does (mostly) work…I say mostly, because my site seems to load so fast that the pre-loader pops up over the initial load so I can see the gears, and then the animation works with a single loop.

Not perfect, but better. :slight_smile:

That’s funny, because I did the same thing just 15 minutes ago and got the same positive result. One thing I had to do to make it work right for my site was to set the delay for each animations to .4 sec in order to give time for pre-loader to at least get going to eliminate any remnants of a double animation. This way, only one animation ran each time (ie. no double animations). I also checked out this change on Firefox and Chrome and it seems to run OK there too.

I think I’ll update my site to use this change and see how it goes. If works OK, I’ll leave it this way. Only thing is if I do any updates to my site, I’ll need to remember to comment out line 11 of unminified blocs.js each time before uploading to web site. If this change proves out, might be nice if Norm could give the user the option of enabling/disabling line 11 in a pref.

Yes, not perfect, but much better. Good luck and thanks so much for your help.

Paul

Two excellent points!