Update Asset Manager so that Images only appear on page being built with a proper click or double click

It is confusing (and after a while super annoying) that images will randomly appear in the document while editing/building a page (in the background of Blocs/rows or in image brics) when that image has not been selected.

Those images generally don’t remain where they appear, though sometimes they seem to. Either way it is quite disruptive to the workflow.

Can I suggest that this be improved so that images will only appear in the document when/if one positively selects these by clicking or better yet double clicking on it.

Thanks!

Switch off preview in place, it’s a checkbox in the Asset Manager. Looks like you enabled it, what you are describing is a feature for quickly seeing assets in place when the cursor is over them in asset manager.