Video runs on Chrome not Safari
was made in blocs. Runs in Chrome but not safari. Any ideas on whats going wrong?

This is all to do with Safari’s treatment of video with a sound track. Nobody really wants a video with sound suddenly leaping into life when they enter a website. If you click the muted checkbox, it will autoplay just fine. It works in Chrome because google like to promote the idea of forcing video ads on to consumers without their consent, so it fits nicely with their business model. This is why many Chrome users will actually turn off the autoplay feature in their browser after realising the inconvenience it may cause them and others around them.


Hm. I checked Muted from the start and still nothing.

Hi @Brettred, I would suggest trying 2 things to get it working:

  1. Remove spaces from the video name (shown as %)
  2. Check if your video is a “real” mp4 file and not just a renamed other format. Handbrake can do this for you.

EDIT: I tried and it solves the problem. Secondly, it reduces your file to 9.5MB instead of 19MB.


I 'm super grateful @Jerry for the insights. I did what you listed and got the same problem :frowning: any other ideas?

I’ve just downloaded your video - it’s quite large as a background video, so I ran it through handbrake and reduced its size to just under 6MB. Wen placed as a background video in blocs it runs just fine. If it’s added to a video bric, it will only autoplay if it’s muted AND is told to play in-line. These are the settings:

If you want to see it working CLICK HERE

The video itself was run through handbrake and optimised for web as well as set to fast decode. This ensures that the video will stream as opposed to loading fully before playing.