Word Press Incompatible Archive error

(I have the latest version of WP and the latest version of Blocs) when zipping and uploading package on wpI get an Incompatible Archive error even if the I have downloaded the package from Blocs for export Word press compatible. Never had this issue before and have been an happy customer for 2 years now Can you please help me :slight_smile: thank you

I’m having the same issue, @Norm could it be related to the last version on Blocs?

1 Like

Could it be that the core pkg on Blocs is non compatible with the latest version of WP? I have asked my domain provider this is what they told me. But hopefully @Norm can help with the fix Thank you

I confirm, I tried a different version of wordpress and now works again

It’s a known issue that started with WP v6.4.3

The native macOS Finder right click “compress” is somehow adding something to the zip file, and WP sees it as an invalid archive.

It’s nothing to do with Blocs.

Just use a third party ZIP file utility or something like a ForkLift.

I confirm too I used a plugin called WP downgrade and placed to 6.4 and voila it works thanks for the tip odd. Lol though it would be nice to have Blocs to be compatible with the latest core versions :slight_smile: CASE SOLVED thanks everyone :blush:

Again, it’s not a Blocs issue!

You don’t have to downgrade Wordpress or anything, just zip your theme with a third party file compression application.


I think the solution could be that blocs saves wordpress websites as zip folders.