Blocs 2.5.0 Beta Build 3


#21

That window problem is still there in High Sierra following a computer restart and having disabled Hyperdock. It doesn’t make Blocs unusable, but it’s unexpected behaviour.


#22

So strange, I just dont get that on my 2 macs at all. I’ll keep an eye on it.

I’ve added some info popovers to help. I also added a little function to scan the string when its inputed and look for common separators and then auto populate them in the separator field. Its pretty automated now all ready for build 4.

EDIT: I also just fixed the typo in the tooltip info.


#23

That should work, but it would be good to have feedback from others. In a perfect world, Blocs could just work out what is required without any need to manually add a separator. I wonder if Blocs could do this in the background somehow and lose the separator field in the interface.


#24

Maybe, but having the separator field makes it more customisable.


#25

I don’t know how many variables there are when copying a bulk group of urls, but most people won’t understand if the copied urls require a “\n” or “\r” without trying, so there is still an element of trial and error to this import process.

I originally thought this would be implemented by importing a physical .txt file and Blocs would read from that. Perhaps that would introduce other problems.


#26

I think for the time being, it’s a feature only those who understand FTP and server side stuff will use anyway. It’s very likely they will get how it works.

Whats there now works, so Im going to leave it and move onto the remaining issues and getting the Dev API out the door :sunglasses:


#27

That’s probably the right call. I guess a lot of users will be sketchy about using any advanced FTP features and most will probably just rely on local resources for adding images.


#28

I’m suddenly having a very strange problem today with a project that was started in 2.5. The Global footer area is essentially unreachable with the bottom blue line being right at the bottom of the editing page with no obvious way to add anything to that area.

I can create a new project now in 2.5 and that seems to be fine, but it’s almost as if the project I was working on has become corrupted during the beta upgrade, unless I’m doing something really stupid here.


#29

Strange, try toggling it on and off via page settings.


#30

No luck there. If I quit Blocs and reopen the project I can see the three areas clearly for about a second with no content, but then the project loads and I’m unable to access that area. You can see from the screenshot how the global footer area is placed hard along the bottom edge and it’s not allowing me to add anything below it.

I’m still messing around and experimenting in this case, so it’s not the end of the world, but it would be tricky if the project had progressed further and I’ve never seen this before.


#31

Anything can happen with the betas.

DM me the project file and I’ll take a look.


#32

A strange one, but earlier this evening I realised I had saved a new project file in the wrong place, so I manually moved it to the right location. Following this I tried to open it through the startup screen for b3, but it launched the project in b2 instead, even though the project was only started today using b3.

I’ve since deleted b1 and b2, but it just seemed like something worth reporting.


#33

This is normal, build numbers are not stored in files.


#34

It seemed strange, given that b3 was already open.


#35

Yeah a weird OS thing when you have multiple versions on the same app on a Mac. The all have the same identifier for the file type.


#36

A quick request that is hopefully not too difficult to include. I’d like the option to add videos to the server as hosted assets, much like we can now do with still images. This could be extended to allow bulk assets for a more efficient workflow.

I’ve actually tried this by selecting a server hosted video as if it was local and it works in preview, but it’s not a logical process like with the still images.

We really need an option for adding poster images as well. A video I’m adding to a page starts with black frames and this is how it looks on the web page.


#37

Trying beta 3 for rewriting my website.
I have a bug with duplicating pages:

When I want to add a new page by “duplicate page” type, duplication works only if I select “home page” for source, not with the other pages I added previously. Create button isn’t operate

I’m on OS X sierra


#38

When adding images as hosted assets in Blocs they stick in the cache. This is no bad thing in theory, but in practice you can change an image on the server, yet still have the old one appear inside Blocs.

I’m using CloudFlare, so they may be a cache effect there, but it would be good if this could be avoided somehow. I’ve tried deleting images and adding them again, but they continue to show as the first version, even after restarting Blocs. It looks like the only way around this is to change the file name.


#39

Same isssue, but if you rename the image the asset manager willl show the new updated image.


#40

Yes that’s what I’m finding, but from a photographer’s point of view you generally want to maintain your chosen file name if creating a gallery. I tried deleting the cache on CloudFlare and the problem persisted, so it feels like this is related to Blocs. Perhaps an option to empty the cache of hosted assets, which forces it to fetch them again from the server.