Blocs 5 publishing to server not working

I am having connection issues when I try to publish my site using Blocs 5. I’m using the exact same settings that I use in Transmit but it doesn’t work.

No issues here at all. Works like a charm. What issues do you have?

Might be worth double checking those settings. The protocols can sometimes be tricky with some web hosts. I was able to connect to my server OK, but the first time I had a silly small point wrong that was blocking the connection.

I use the exact same settings I use in Transmit.
Capto_Capture 2022-11-24_06-05-17_pm

path is wrong, thats a URL the path should be the location on the server eg /blocs/ or /httpdocs/

You need to check what the root location is with your provider.

1 Like

Thanks Norm. I used the following path: public_html/test and it now works fine.


no connexion possible on my server:
it requires this protocol: “Use explicit FTP over TLS if available”

When I publish and click on “Open in Browser” it gives the following incorrect address when opened:
It is adding the ftp prefix to the url and also not using the path set in Path: public_html/test
Everything uploads ok but I have to manually change the url to Home to view the uploaded site.

@Norm - one of the features i really wanted for Blocs 5, sadly doesn’t seem to work for me and i have no idea why. im not a coder, im a keen amateur, but i read the comments above and think ive got everything right. Still no joy.

Ive tried every possible setting i can find:
Passive mode enabled, disabled.
FTP with implicit SSL

nothing seems to work, im pretty confident the path is correct, the password and username are correct as i can access it with these credentials via Forklift.

Im sure ive missed something but not being very knowledgable i just dont know what. any thoughts?

The path looks wrong, that should be like the file system path on your server. I don’t think it can end with .org

the path does indeed end in a .org on the server i copied and pasted it directly from the web host. pic attached

Screenshot 2022-11-24 at 19.19.20

An example for our server for path is /httpdocs/iPad-test/

On our server we have a directory called iPad-test in the httpdocs directory, which is the root directory when connecting over sftp.

ok, So ive changed the file path on the host to remove the .org and updated all of the other details so the site works. But i have tried every option again to publish it from Blocs and still no joy.


Try putting leading and trailing slashes


sadly no luck, that didnt work either

Hmm maybe I can try and connect and see if I can sport the error. Obviously this would need to be done private support request.

What if you do it without the /public_hml? So, just /sim-academy(.org) On my server, the path is /www/websitename. Though on the server it’s /home/www/websitename.

Worth a try :wink:

1 Like

thank you, but that didnt work either.

thank you, how do we do a private support request? how does that work for you?

Awww. Sorry, hope you get it sorted.

1 Like