Blocs for Mac 5.2.0 Officially Released πŸš€

We are very happy to announce that Blocs for Mac V5.2, has now been officially launched :tada:

You can read the full release notes here and the blog post all about this release here. :open_book:

Thanks to all who helped to test this release :raised_hands:

New Features Documentation
You can access the latest documentation for some of the new features below :point_down:.

β€’ Horizontals Scroll Container.

β€’ Lock Classes.

β€’ Share Preview with Air Drop.

β€’ Share Webpage Screenshot.

β€’ Auto Apply @β€Œ2x images .

Having Problems?
If you encounter any problems with this release of Blocs, you can access all previous versions on Blocs V5 here (scroll down).

As with all new releases, there may be some remaining problems and compatibility issues, as well as this we have some fixes we think need a little more testing, which means they have been left out of this release. With this in mind, we aim to release the first beta of Blocs for Mac V5.2.1 by the end of the week.


Preview mode returns a blank page. However, 5.2 beta 12 worked fine.

I would suggest redownloading, reinstalling and restart your Mac.

Not a great deal changed between 12 and release so it may just be something kind of permissions error caused by in-app update.

Volt CMC not working any more. Blog page shows strange things. No editing possible, I go back to 5.1.5

1 Like

Interesting, pretty sure a few tested used Volt CMS without issues.

Any chance of a screen grab of the error so we can look into it?

without issues.

It’s nicely messed up. :face_with_symbols_over_mouth:

1 Like

No sorry, I’m back on 5.1.5 now and working on for a client.
But it looks like some scripts/PHP/CSS were not loaded. Editing was not possible, the posts were messed up and the galleries inside the blogs were squished.
I will try the next Beta maybe Friday/weekend and investigate further.


airdrop don’t work… :upside_down_face:

It could be an OS issue, this trouble shooting guide may help.

We are back to the slow downloads. Curiously it doesn’t affect in app updates, but only those from the website. It’s taken half an hour to reach 11mb.

EDIT: If I stop the download after it has started, then click the reload option it downloads quickly.

Mail shot just went out to lots of users, could just been the server being beat up.

Perfect. After your advice, it works perfectly. Even with Volt CMS.
Many thanks to you
And a very happy festive season to you.


The old, turn it off and back on a gain never fails!

It happens every time if I try now. First attempt is horribly slow, then stop and reload makes it fast, irrespective of which point in the download I try.

Which browser?

I tried Safari. I can check others if you want.

It was from this page Blocs Website Builder - Release Notes

Near instant for me to download.

But then living in the southern hemisphere, means the bytes were flowing downhill :smile: :rofl:

1 Like

Like water in toilets flows out the other way round? :wink:

1 Like

There is a problem with Volt Blog. It does not work. See the image. It is not possible to edit the blog posts.

When I use Beta 5, everything is fine.

1 Like

UPDATE - reverted to 5.1.5 and now displaying correctly and is editable again;

I am also getting exactly the same problem with VOLT with oversized images and no ability to edit.

1 Like