Blocs V5 - discovered bugs so far

Hey @Norm,

having fun with V5, but I discovered ome bugs I’d like to report:

1
I have a row with 3 columns. On medium breakpoint I have col 1+2 take up a width of 6, the 3rd a width of 12. In the editor it looks ok, but when I preview and reduce the screen size, it behaves oddly: The 3rd col does fill the width of 6 eventually, but before that it kinda glitches:

2
The image on the page (see: fynndesign - Webseiten für Individualisten) is a rounded image with a set width and height. Yet google page speed moans, that the image does not have a set width and height. Any idea why?

3
Lastly, when I publish it to the server and choose “Open in Browser” from the dialog after the publishing, it does not take me to the url of the exported site, but to the host adress.

4
I cannot delete a blur backdrop filter that I added to a class. I delete it in the class, click done. Filter is still applied. Open the class editor, and the backdrop filter is there. Can’t get rid of it.

Oh, and generally: is there away to enable or change the font-display propery globally? That’s something else that page speed insights complains about and that I don’t know how to change globally.

An issue I have - where I need help.

For a few weeks now I have trouble viewing images in Safari, on 50% of websites on Safari I get a small blue box with a question mark on it with no image. With doing everything every forum and help website have suggested, still no good.

This has lead me to use Google Chrome instead - which has worked great.

but with Blocs 5 for the 1st time, on all the templates Norm has brilliantly added - I can’t see any images. Does this use Safari extensions when building?

I am guessing this isn’t a Blocs issue - buy my Mac issue!!! - I will be buying a new MacBook in the next few weeks anyway, but hope to use Blocs 5 on this mac.

I have had Blocs 5 crash a few times too - using Catalina 10:15:07

1 Like

thanks.

  1. you can set these with custom attributes, the sidebar fields for images set the values into classes. Just select the image and add attribute width and set a value.

  2. Try setting the address in project settings.

Something up with WebP. Those images are webP Images. Are you using MacOS 10.15?

2 Likes
  1. The image has a class that has set it’s width and height for each breakpoint. Works in Bootstrap Studio. Not here :wink: The page is online, so you can check.

  2. Adress is set correctly in project settings.

Hey @Norm - thanks for the reply.

Just edited my post, as new this would help, but using : Catalina 10:15:07

Is their a problem with 10.15.07?
I am considering upgrading my OS to Monterey, would that fix it?..I feel it could just be a browser issue?

I found in the CLASS window, I can’t drag my mouse to make value changes. Have to type in the value. Am I missing a setting to allow what I had in 4.5 ??

Thank you
John

That there is your problem. Catalina doesnt support WebP on an OS level. What hardware are you running that you are still on Catalina?

2 Likes

Thanks @Malachiman - just updating it now!
I was running this machine on that OS as a Roland video switcher and Chamsys lighting software I used was really stable with it, but have an older MacBook Pro which I can use for that.

1 Like

Our ChamSys QuickQ 10 is working well. For the most part, the presets have been wiped a couple of times, by experimental people who shouldn’t have been on it. :joy:

1 Like

Brilliant!!

I have 2 x Quick Q20’s, so much cheaper than Avolites Quartz desks. I had the first batch of UK prototype ones and they did me such an amazing deal, but now trade its over double the price I paid - but well worth it.

I knew it inside out and then they did a huge update 9 months later its release and everything changed! but my freelance crew know it inside out.

Such a great little controller and once you find out where things are hidden, its great to play with.

I am now running Monterey (Thanks for the advice) and just had to re-download the Quick Q software - all working good!

1 Like

Created a new page, (cloned an existing page). Changed the background image of one of the blocs and it shows in Blocs the program but does not show when testing the site or when I have exported the projected and uploaded it onto my server.
Now have a page with an empty/grey area.

I still know very little about it lol. Lighting is such a different beast to get your head around. The controller is cool though. We got an excellent deal due to one of our guys being in the trade.

1 Like

I had the same problem this morning when I was testing v5. I have not had time to investigate more. By the way my images are all jpg.

1 Like

Nice upgrade!
But: Why such a ridiculous upload manager?!
Microsoft did that better in “Frontpage” anno 1998!!!
It’s almost an insult, seeing the promo video.
Nevertheless: Congratulations.

And where did the internal link go to be able to test his devices in his own network!
I feel sorry for you @Norm … these days!

Hate to jump in here…does this upgrade path change the Blocs 4 application to Blocs 5?
Can I still run Blocs 4?
Asking because I’d like to use the discounts available to purchase Blocs 5, but don’t want any bugs in 5 to interfere with my daily site updates, so I’d like to continue to use 4 for now, but own Version 5.

Thanks for any explanation…

Rich the Weather Guy

You can change the name of the Blocs 4 application to Blocs-4 and have both installed

That was what I thought. I have already done that, changed the name.
So…then once I upgrade, I assume I will need to shut that application down and relaunch my Blocs 4 installation to go backwards?

At that time, I assume I will see a new “Blocs” application in my application folder?

Do I have that right Pete?

Thank you

Rich the Weather Guy

Yeah. Just be aware if you open a project in Blocs 5 you won’t be able to open it again in Blocs 4.

This begs one last question…on my laptop, since I won’t be “upgrading” Blocs version 4 there, how do I install version 5?

Thanks again…

Rich the Weather Guy