Pre-Loader Bug?


#1

Hi, on my sites doesn’t work the preloader. is that a bug? three examples:

http://www.hungrybirds.eu

http://www.trainingsmacher.de

http://www.hairapartment.de


#2

Could it be the load time is so fast you don’t see it? all three loaded instantly for me on a 76mbps connection.


#3

Same here the load speed was impressive (300mbps), quite jealous.


#4

Impressive, your server and site are optimised well so it’s loading blazingly fast!

Who do you host with?


#5

The websites load very fast for me as well, but I do believe that pre-loader is not working sometimes, because I have the similar issue with some of my websites as well.


#6

Same here.
Sometimes when you make changes on your project and you upload it to your server the pre-loader doesn’t work anymore.
You must then implement it again, export your project and upload it.
This is almost daily routine.


#7

When you upload, make sure you re-upload the new HTML and the new JS as these files change per export depending on whether a pre-loader is used or not.


#8

Ok, thanks!


#9

I’m having the same issue. Despite a complete upload of the site (after deleting the old one), the pre-loader simply doesn’t show up. The page uses a Hero bloc with an animated title. When the page first loads, the animation messes with the page layout - forcing all the text to the top of the page before finally settling down once the page fully loads. Normally, the pre-loader would mask this effect, but for some reason it’s stopped doing it.


#10

Is everyone viewing in Safari? In Chrome, Firefox, etc., you see the preloader for a second, at least I do on a 150mbps+ connection.

dogado .de - is the host for all 3 of those sites.


#11

I always do that

The pre-loader is NOT showing on Safari. All other browsers (Firefox, Cliqz, Chrome, Vivaldi) are OK.
Running 10.13.4 BETA 5


#12

That was my point. :wink:


#13

Ah! it seems to be a browser problem - works fine in Chrome but not in Safari.


#14

yeah I get that at the office but not at home.


#15

Actually I remember now, I had to remove the pre-loader from Safari as it had a habit of getting stuck if there were video backgrounds or videos on page.

Basically Safari doesn’t class the page as fully loaded until all videos are completely parsed and it was really slowing the page load speeds down. The other browsers don’t force this and the spinner usually goes after seconds of the video being initially parsed and doesn’t require the completion of the parsing in order to trigger the page is loaded event.

Im almost certain its in the release notes in the last few releases.


#16

I might have missed it.
Are you going to fix it?


#17

Ok. Please could you fix it. Because the problem is the animation in safari. that doesn’t work fine without a pre-loader.


#18

It’s not possibly from what I can see, Safari doesn’t call the page loaded event until after the full video is loaded into the memory, I’ve no idea why that happens. I can re-enable but if your visitors are on Safari and you load a video from youtube or your own hosting, you page wont show until that video is fully loaded, people will just leave your site.

So unless someone can enlighten me with a good robust workaround, pre-loaders currently cant work on Safari as they cause unwanted pauses in page loads.


#19

@Norm can i post a video to show the animation problem without a pre-loader? it doesn’t look good. in this case i have to delete an animation.


#20

Yeah I understand, but its something I tried to fix and simply couldn’t. You can manually remove the snippet that Blocks it in Safari if you want, but it if any of your pages include video bg’s or load videos it will slow it down considerably depending on how big the video BG is.

To manually bring back the spinner in Safari.

Export your project and select to not minify the blocs.js.

Open the Blocs.js file and remove line 18.