Publish - connection error, test was successful

I’m setting up a new site. I added the server credentials and the test was successful. I’m using SFTP with the current version of Blocs for iPad. After clicking “publish site” I get this long connection error. How to fix? Also, I’m not able to close the publish popup window after trying this, seems buggy. Thanks

Check your upload path, this usually means the server path you are trying to upload into doesn’t exist?

Hi Norm. I just spent an hour with my hosting tech support and we couldn’t figure it out. All credentials were triple checked. We tried whitelisting the IP, and tried FTP (thru blocs), no luck. They suggested I use an FTP client outside of blocs, but it’d be nice of course if I could just use the publish functionality within blocs, way more convenient. Any other ideas, please help, thanks

What value are you entering into the path field?

Path value:


Sorry for delayed response, I’ll be around now, thanks for helping!

Any luck amigo? Trying to work this out thanks

Can you continue to help please? Much appreciated!

Norm is on holidays. I’m sure he will get back to addressing this after his well earned break.

Ok thanks no worries!

Norm you there?

Path value:


Anyone??? Please help!

1 Like

That seems like a weird upload path to me, but I’m not knowledgeable on all different types of servers.

I would normally be using something along the lines of
ftp.hostname (, .com etc)/clientname (, .com etc)/public.html

Yours may be correct, just trying to offer my insight.

Thanks mate. No luck yet.

I have triple confirmed the path and all other credentials are correct from my server. They’re not able to figure it out because they’re not familiar with blocs.

Is there more reliable support here than the forum? I’d really like to be able to use the publish function without going the export ftp route.


Hey, sorry I missed your replies in this thread.

Which location does your FTP account start you in when you login on the server? Not all FTP accounts start you off in the root location.

Howdy Norm, I was able to connect with a different path a couple days ago, but now I’m getting a new error and can’t connect again.

New error:

New path:


And to answer your first question, I was using master user login. This is what they told me:

And, connection works through FileZilla, suggesting the issue is within the blocs app. Thanks for helping!

You might want to hide your credentials from the screen shot. :man_shrugging:

1 Like

Norm? Anybody home?