Reset font style to inherited after changing font type

By default all font settings in the project settings panel are set to “inherited” which means all type styling uses the font you set in the “ALL” setting. Now if I set, for example, the font type for H1 to something different than the font I set for “ALL”, I can never go back to the “Inherited” setting. The inherited setting just disappears from the options list.

So my wish is: keep the inherited option so that the user can “reset” a font back to inherited after the a font change has been applied.

2 Likes

I hope this will be taken into consideration. This makes writing custom classes very hard. If I set a different font type at a given break point, and then change my mind, I can never go back to the default setting.

For example: in the global settings I defined a font for all H2 tags: Roboto, 1.5 rem. Now I create a custom style for an H2 tag with Lato, 1 rem. Once I do that, I can never remove it from the custom style. There is no way to “reset” the or remove the setting to revert back to it’s global default.

Also this seems to be inconsistent - for example: I can remove the font size in a custom style by simply deleting the size entered in the size box. Also I can even delete the font color by clicking the little (x) next to the font color setting. But the font type can’t be removed ???. Doesn’t make sense …

1 Like

+1 here - please add inherited to the list of fonts (or a reset button)
I just bought Blocs 3 and played around with these settings. I changed the font for a breakpoint and was quite surprised I can not get back to inherited. I think this is a quite “dangerous” bahaviour and can lead to a lot of work once this setting has been changed unintended or just out of curiosity.

1 Like

I made this request a while back as well. As a temporary workaround I suggest testing fonts using the side panel on some specific pieces of text, then only applying it in project settings when you have decided what to use. Inherited settings can then fall neatly into place without disturbance.

1 Like

@Norm when are we going to get this fixed?

1 Like

Not sure if my problem is related, but maybe this will get more eyes on it…

1 Like

Just started using Blocs and came up against this issue very quickly. :frowning_face:

All that is needed is just a ‘Default’ or ‘Inherited’ option in the font list.

1 Like

+1
Am I missing something or is this still not solved?