Unable to remove assets in the asset manager


#1

I can’t remove any assets in the assets manager. I right click on an asset, select “remove” and it removes the asset from the asset manager and on the page where the asset was placed.

Then I save my work, close Blocs, then reopen it, and all the assets I removed are back in the asset manager. I can’t remove any assets from the asset manager. They just keep coming back!

Another thing I don’t understand: in the asset manager window there is a plus and a minus symbol at the top right. But only the plus symbol works. Why put a minus symbol if it doesn’t have any function?

The only thing that remains “removed” is where the asset was on the page. It’s replaced with the placeholder image.

ALSO: ALL the assets that are loaded by Blocs when you create a new site (B&W photos, patterns, other photos, etc.) are still listed in the asset manager, even though I’ve removed them at least 100 times.

What am I doing wrong? Or is this a bug in Blocs?


#2

This is causing me big problems. If I change a graphic, save it with the same name, and then go into the asset manager and right click refresh asset, nothing happens. Also, since I can’t remove the old asset, I have to export my graphic using a completely new name and then import it into the assets manager.

Now I’ve got 3 slightly different versions of the same asset listed in the asset manager.

I hope this gets taken care of soon.


#3

Are you removing the asset from the group or the project?


#4

You should also be able to replace assets. The refresh issue can be application cash, preview mode will show the latest version of the asset and if you close the project and re-open it the asset will also refresh.

Because Blocs give you a pretty close live representation of your site while you design it, sometimes images can get a little sticky if they are edited while Blocs has them on screen.


#5

I recommend reading the docs for the Asset Manager. Especially the removing asset ones, it explains how and when the minus is activated for us.

The second video example in that section actually demonstrates the minus button.


#6

Hi Norm, I’m not sure how to answer your question if I remove the asset from the group or the project. I can see only 1 way to remove, and that’s with right click on the asset in question.

Or do you mean: if I create an asset group like “Logos” and add an asset to it, in order to remove that asset completely I have to switch to the “All” list and remove it there?

What I did was: I added a jpg to a group I created using the asset manager overlay. Then I opened the group in the asset manager and right clicked on remove. The image was removed from the asset manager and also on the page it was on.

Now I save my project, close Blocs. Reopen the project and the asset is back in the asset manager.


#7

strange! Well 3.2 is about to start its beta so I’ll see if I can replicate the issue and get a fix in if required over the next few days.


#8

Here’s a quick screencast I just made …


#9

new Beta, cool! I hope though I won’t have to rework all my 3.1 sites like I had to do with the upgrade from 2.6 to 3 … but I guess that was just because of the move to bootstrap 4 …


#10

Another screencast. This time I created a completely new project, deleted the dummy images, and saved it to my desktop. Then I closed Blocs, reopened it, and … the deleted assets are back …


#11

No you would need to rework them. This update is more abit building onto what version 3 does, it doesn’t really effect files unless you use the new features.


#12

I know you guys are busy with the next big release … but i just can’t seem to get a handle on the assets. I read the online documentation, nevertheless …

I removed an asset as outlined in the documentation. I am 100% sure it has been removed. Then I saved my work and closed blocs. Then I deleted the files from my hard drive.

The next time I opened Blocs, I was prompted with a “Missing Assets” warning. I definitely removed these assets. Why am I getting a warning that the assets are missing? I removed them from the assets manager. How can it be that Blocs warns me about missing assets, when the assets are no longer listed in the Assets Manager?

Honestly, I just don’t get what I’m doing wrong.


#13

Hi Gary,

When you open Blocs next time, right click on the error message and remove it. It should solve the problem.


#14

THX Eldar!


#15

Still: if I remove the “Blocs placeholder graphics” (the ones that are in the asset manager when you create a new project) according to the method shown in the Blocs documentation, They reappear the next time i open the project.


#16

Hi Gary, did you already solve this problem?


I can't remove assets in the assets manager
#17

No matter what removing image assets from Blocs is not fun. Hoping one day we be able to select all or a section and simply delete them.


#18

unfortunately, no … actually, I can’t even remove my own assets. See this: https://www.useloom.com/share/963c77781e9b4bd4aa114bea4e3b078b


#19

Have you tried right clicking the image asset and open it in Finder?
Perhaps you’re deleted it from a different location then the one showing in your Blocs image library. Just throwing this thought out there.


#20

Gary from my experience I solved it this way.

Blocs link the asset with the original file and folder where it’s placed when it is imported.
So if you delete the original asset (not in the Blocs app but in the original folder or the folder itself) when you open Blocs the app will tell you that asset is missing and you could ignore it.

I’ve had a lot of issues to find out how to solve this after so many graphic and image exploratory tests I have done for a project.
This way I solved the problem and no more assets appeared after being removed.

Tip
What I know is this: I prepare a folder just for testing images and when I decide what to do I erase all the test files or erase the respective folder

Hope this help you.