Vertical margin adjustment no longer works in 3.2.1

One of my favorite features of Blocs 3 was the ability to visually adjust the top and bottom margin of an element. This was done by selecting it, then holding down the shift key to reveal the handles that I could grab and use to adjust the margin + or -. I just downloaded 3.2.1 and see that no longer works. @Norm, is that a bug or did you eliminate that wonderful feature??

1 Like

I can’t confirm.
It works perfect here.

@Bootsie, In 3.2.1??? I just un-installed 3.2.1, restarted my iMac then re-installed and launched 3.2.1 and have all the same issues. I’ve found several issues so far and keep finding more. And now it appears the Blocs forum site is buggy. I had problems logging in (I got the Google warning; 'Warning: This website is not secure, etc. etc) Because I know (or at least believe) it’s safe, I continued anyway. But then had issues with my screenshot attachments being blurred on my post… It’s not been a good day in Blocs world…

Here’s a link to my other post which details several issues:

@Creative @Norm I reported this as a bug last night. It happens to me occasionally and then restarting Blocs fixes it. I think this started with the betas of 3.2.1 and carried through to the release.

@Flashman, that’s interesting. I’ve restarted multiple times and it persists. Thanks for the feedback though! Please let me know if you learn anything or hear of a patch…

Any patch will no doubt be an update. For me it happens about once a day where I suddenly find it doesn’t work. Restarting Blocs then clears the problem for a while.

Blocs 3.2.1 stops freehand triggering if more than 1 key is held down. This fix was introduced to prevent the flashing guides when typing in text areas and using shift for temp capitols.

I’m wondering do you have any broken or sticky keys on your keyboard?

I can confirm the same issue and that a restart fixes it for awhile, but it eventually returns prompting another restart.

1 Like

@Norm, nope, I checked and sticky keys were not enabled. No broken keys. I only hold down the Shift key to use the freehand margin control. (I LOVE that feature and have become accustomed to using it often). It’s second-nature now to hold that Shift key down to access those little handles. THANK YOU for such a great feature by the way! I’ll wait for 3.2.2 and try it with a copy of my project before opening the latest actual project version. Warm Regards, - Randy

PS: What’s up with the forum today? I’ve seen others report too that they’re getting the Google warning message that the website is not secure and potentially unsafe. (see screenshot)


1 Like

We use a service provider I’m making them aware to see what the cause is.

1 Like

The site is opening fine here with no SSL problems.


1 Like

@Flashman, would you include the link in text format? I can’t see the image…

@Flashman, I get the same Google warning screen with that link…

You are effectively going to the same place so that’s unsurprising. It was merely a screenshot showing that the SSL certificate is valid when viewed in my browser.

@Creative You may find that flushing the DNS cache in terminal then restarting he Mac fixes your problem. The correct command will vary according to your OS version, so you may have to Google that.

@Flashman, thank you. Either that worked, or the issue was resolved in some other way. I had no idea there was even a ‘dns reset’. On the one hand, I love learning new things every day. On the other hand, the realization that there are so many important things I don’t know terrifies me. lol Thank you again!

It likely would have cleared itself eventually, but this would have given you a clean slate and fetched the current information. The other day I added DMARC to my sites in cPanel and it checked out immediately when I ran a checker, but it took the likes of Google around 24 hours before their DNS cache was renewed and the correct data appeared in the mail header.

How do you flush the DNS cache on a MAC


  • Step 1: Open the Terminal
    • Navigate to Applications -> Utilities -> Terminal
  • Step 2: Flush DNS - Type the following command and hit enter.
    • Mac OS X Yosemite and later
      sudo killall -HUP mDNSResponder

I’ve seen different options. For example this one for High Sierra:

sudo killall -HUP mDNSResponder; sleep 2; echo macOS DNS Cache Reset | say