Blocs 2.5.0 Beta Build 3

@Norm I’m seeing a weird behaviour in 2.5b3 when creating a contact form, where text is not visible on the submit button. I removed the original form and tried again, but the problem persisted. I then fired up 2.4.5 and it worked correctly immediately.

I have a strange bug:

When I want to duplicate an existing page using right clic mouse, it’s duplicate the bloc on the selected page instead of duplicate the page

Do you have the same problem ?

I just tried and it worked for me, but I discovered another problem. In two cases the previews do not accurately reflect the hero blocs on the actual pages. The home page preview is missing the image entirely, though a duplicate did show it.

Meanwhile the copyright page still shows the default image instead of the correct one when I visit the actual page. For some strange reason, I am unable to duplicate any page other than the home page and right click doesn’t work at all.

There is also a preview glitch inside 2.5b3 if I have elements hidden at specific device sizes. Basically I end up with a big blank space, but if I preview in a web browser it looks correct. For some strange reason I’m seeing lots of glitches in b3 that were not apparent in the earlier betas, so I’m wondering if I have a bad install for whatever reason. I’m on 10.13.2.

You cant duplicate pages with a right click, only blocs, looks like the right click is detecting the Bloc underneath the page thumb.

To duplicate a page select duplicate from the sidebar page menu then hit the create button.

Blocs doesn’t let you duplicate pages with a right click.

Try saving the project and opening it in 2.4.5 to confirm its defo 2.5 b3.

Just checked in 2.4.5 and it has the same problem with hidden blocs leaving a blank space when previewed inside Blocs. If I go to View > Preview in browser it appears correctly.

The process of having to add hero blocs more than once to account for different devices seems convoluted, which is why I suggested it all be done in one bloc Hero bloc image choices

ok so it looks like the duplicate page function isn’t working correctly in 2.5. I’ll get this fixed ready for build 4.

ok this is all fixed and ready for build 4.


Certain project keeps crashing on startup - others are fine (all on same iCloud-Folder)…
Also no issues when opening in 2.4.5.

Crash report:

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: '*** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[2]'
abort() called
terminating with uncaught exception of type NSException

Help very much appreciated! Running High Sierra (10.13.2) and 2.5.0 beta 3

Do you get the crash with 2.4.5?

Thinks Norm :grinning:

No crash on 2.4.5.

1 Like

Could you DM me the file please.

Just sending via wetransfer right now … and done.

1 Like

Ok so I just opened your project with 2.5 beta build 4 and it opened fine, no crash.

Try build 4 when its available and let me know if it continues to happen. Hopefully its fixed.

1 Like

This looks like a class issue, I think I can see the text in the button but its really small. Any chance of sending me that file so I can take a look please.

Thanks Norm, I´ll wait and tell you.

1 Like

This issue is now fixed and ready for the next build.

Bulk import of hosted videos already works?

Sorry missed this one earlier. Yes it seems to, but the process is a bit disjointed in that you first have to select “Local File”, but having done that, you can locate bulk asset videos just like the images.