Bulk Add of Hosted Assets Still Not Working

This has been my one and only complaint about Blocs. If I’m doing something wrong, please tell me what. It can’t be that the problem is that I’m using Cyberduck. Because I’m passing the urls through BBEdit and they still don’t work.

But worse. They not only don’t work, they lock up Blocs so I have to quit and restart it to continue to make progress. I’m adding hundreds of assets and I’ve been doing them one at a time for the last 2 years and this is really getting to me.

If I paste the urls here in this message, the forum software recognizes them and shows them as images. So, there’s nothing wrong with the URLs. Indeed, if I put the URLs into Blocs one at a time, they work.

So, what is the magic potion. Why can’t Blocs realize that what it’s trying to do isn’t working and give an error message? It is unacceptable that it goes into an endless loop.

The site can be found at: DaveSofNJ Bird Photos

I’m loading the hosted assets into folders inside: http://www.wanamassa.us/davesofnjassets/

Is the problem that my site is not at the domain’s top level? Even if that is the problem, Blocs should not go into an endless loop.

Help please!


Your links are incorrect e.g http://ftp.wanamassa.us/davesofnjassets/TopPagesArticles/CANG_P4150015_0400_FirstBirdPhoto-2250.jpg

That “ftp.” part doesn’t look right. Try removing that and see if it works. It almost looks like you are storing the files in the wrong place on your server, but if you use an app like Forklift I don’t think you would have this issue.

1 Like

If you are copying the link from the ftp client it will be prefixed with ftp (usually). As @Flashman mentions you will need to amend this.

I’ve removed the ftp., I’ve left it in, I’ve replaced it with www. Makes no never mind. Works in the site whichever I use. Works if I import them one at a time. Won’t work if I try to bulk add them. Same result whichever form I use.

Thanks. I appreciate that people are trying to be helpful. But none of these suggestions makes a bit of difference. They work in any of those forms if imported one at a time. Blocs goes into an endless loop if I try to import them in bulk.

Have you tried using a different FTP app? I have zero problems with Forklift adding bulk assets. The app has to copy bulk apps with the correct formatting for Blocs to work.

Here is another issue. Your links go to http:// but your site is at https://www.wanamassa.us. Note the difference with the https://

Blocs is not the issue here. Bulk loading of assets 100% works properly but you have to feed it the right links in the correct format.

Well you don’t have to agree, but the warning on your website suggest we are correct. Fix the URLs you are using.

I know @Flashman uses hosted images all the time with no issues.

1 Like

Hmm. Why do the links work when used one at a time?

Why is it acceptable for Blocs to go into an infinite loop from which the only escape is to restart the app?

But I had forgotten I’d changed to https: I wonder why Cyberduck isn’t picking up on that. I’ll try that in BBEdit and see what happens. Thanks for pointing that out.


It’s likely the server is timing out, not a Blocs issue.

Nobody else is reporting issues with adding bulk hosted assets and if you go through this thread, plus others you have started on the same theme it seems you have some issues understanding hyperlink structures, while also battling with Cyberduck.

Very likely you haven’t updated the bookmark destination link in Cyberduck to reflect the new https status. I don’t really think you can blame Blocs if you are consistently feeding it links with improper formatting.

I understand that I’m having trouble. I understand that people using Forklift are happy as clams. I also understand that Blocs goes into an endless loop when presented with a text string that it doesn’t like.

But I’m not blaming Blocs for my problems. I’m trying to get help so I can get past this.

You said:

which at first sight looks like just the kind of information I need. But Cyberduck help doesn’t recognize the words “bookmark destination link” so could you spare another moment to tell me how to do that?

I’m absolutely convinced that I’m missing something fundamental, but every time I ask for help people tell me that I’m the only one having trouble and I believe that and that’s why I keep coming back and asking the same question.

What is the difference between bulk add and single add?

Oh dear, the plot thickens. I tried to take Cyberduck out of the equation by editing the urls it provided in BBEdit. After the edit, I had these four URLs (I’ve deliberately broken them here by adding a space before the final period, otherwise the forum software would display the images):

https://www.wanamassa.us/davesofnjassets/HOGR_gallery/HOGR_IMGP7315_2204_OnWater_600Square .jpg
https://www.wanamassa.us/davesofnjassets/HOGR_gallery/HOGR_IMGP7315_2204_OnWater .jpg
https://www.wanamassa.us/davesofnjassets/HOGR_gallery/HOGR_IMGP7346_2204_OnWater_600 .jpg
https://www.wanamassa.us/davesofnjassets/HOGR_gallery/K1FD4151_COLO_HOGR_2204_OnWater_600 .jpg

And Blocs’ behavior was a huge step forward over yesterday. Instead of going into an endless loop, it told me that it couldn’t find any valid urls in the string. It did this whether I used \r or \n as the separator.

And yet, when I tried the urls one at a time, it worked perfectly.

And now, when I’ve tried once more because I wanted to quote the exact message in the dialog that Blocs presented, it’s gone back into endless loop failure mode.

So, I’ve taken Cyberduck out of the equation by passing the text string through BBEdit. I’ve proved that Blocs likes the urls in question by presenting them one at a time. I’m at a complete loss. The only variable that seems to be under my control is the separator that Bulk Add should use. Is there something other than \n or \r I should be using? BBEdit, for what it’s worth, recognizes the separator whether I use \n or \r in its grep find. [I’ve reread the user doc on this separator issue and it seems that Blocs is auto-selecting \n, so that’s not the problem.]

This is one of the most frustrating problems I’ve ever had with a computer since I started using them in 1965.



I once tried Cyberduck for about 10 minutes and concluded it was a bit of pain. It just didn’t work like other FTP apps such as Yummy, Fetch, Transmit or Forklift, so it felt unintuitive.

I don’t really have time now to install Cyberduck and go through all of this, so I would suggest contacting their support channel, since that is the cause of your difficulties here. Your destination bookmark is simply the location you are connecting to on the server saved for future use.

The difference between adding bulk and adding single links is that each link needs a separator to define them properly. If the links are copied correctly Blocs will add this automatically with something like: \n

I just took your links and closed the gap then pasted them into Blocs.


They work fine for me here when added as bulk assets:

Screenshot 2022-01-09 at 14.38.23

Try copy pasting from the links I have added above.

Thank you very much for the effort you’re putting in here. That you were able to add the assets while I can’t points to the problem being my setup.

We can rule out Cyberduck as being the issue here. I just did what you said and it failed in the same way as ever: the bulk add dialog has to be canceled and then the Asset Manager window is greyed out with circling arrows indicating an endless loop.

I’m not even using the same computer as when I started having this problem having traded in my Intel 16 inch MacBookPro for an M1 model.

FWIW, the string you posted is identical to the string I created in BBEdit.

So, it sounds like something is misconfigured on my computer. Perhaps I should uninstall and reinstall Blocs.


It should work for you like here in this video.

If that isn’t the case it’s hard to know what else to suggest. Previously you definitely had issues with incorrect url links, which would have caused problems for sure. If you have problems viewing the video you can right click and save it to your desktop to view larger.

As shown in the video, make sure you are choosing the option to Bulk Add Hosted Assets.

Screenshot 2022-01-09 at 15.13.45

I don’t usually use Hosted Assets but do upload with ForkLift 3 and here it doesn’t work for me either. Just wanted to give it a try out of curiosity. I did exactly as shown in the Flashman video. One image at a time goes well but with 2 or 3 images I also get the circling arrows and have to close Blocs to continue.

That’s most likely a network issue and might be related to your hosting. Are you right clicking in Forklift to copy the selected urls like this?


Another thought, but have you designated a specific folder for the assets like _images to hold the files? I’ve never tried it but attempting to add bulk hosted links from the img folder may create issues.

Yes I copy the link I get from ForkLift and modify it. When I want to add a single image it goes well but as soon as I try 2 or three it doesn’t work. No problem for me but if you want to add multiple images at once then it drives you crazy I can imagine.

Yes, I’m doing it exactly as shown in the video, but no the assets are not added for me. Instead, the dialog doesn’t go away and if I dismiss it using Cancel there’s a circling arrows icon indicating that Blocs (or a Blocs thread more likely) is unable to complete its activity. It is still possible to use Blocs to some extent when it’s in this state, but the best thing to do is to quit and restart it.

I see that I’m not actually alone with these problems.

But again, thank you for the effort you’re putting in.

Also, while those earlier links might not be pristine, they all worked when added one at a time; they simply couldn’t be bulk added.


Thank you for speaking up! I was feeling very lonely with this problem.


You shouldn’t need to modify the copied link. Just paste it inside Blocs.

Did you set the base url for the ftp server bookmark in Forklift?