How to Create A Simple Lightbox Gallery

Hi. A newbie Blocs user here. Loving what I’ve created so far, but I can’t get my Lightbox galleries to work. I followed the instructions in this video, but nada!

I have two galleries - one called France, and one called Italy. Each gallery has a hero image, with six more images that I want to appear in each Lightbox. I’ve set the Interactions settings for all the images to Type: Lightbox; and the Gallery is set to either italy or france.

When I toggle the View Mode, Preview in Browser, or do a Quick Export, and click the hero image for a gallery nothing happens :frowning:

I’m sure I’m missing a trick somewhere. Do I have to create and assign a class? Or download a script for this feature to work? Or can someone point me at some instructions on what I want to do.

Thanks in advance!

I do see an occasional quirk in blocs when galleries don’t display correctly when set up as described in the video. Firstly, make sure that your lightbox setting are set to display CURRENT IMAGE - sometimes it sets itself to alternate image. If that is not the issue, save your project and close Blocsapp. Reopen your project and the galleries should work just fine.

Thanks for the quick reply. I’ve checked all the assets. All my Lightbox images are set to Current Image. I’ve saved the file and quit Blocs. But still no joy when I opened it.

As this is only a demo site, it maybe quicker to delete the Lightbox galleries if this is a function that doesn’t work in Blocs.

Yes, I have the exact same problem as @DerekDigital
Time ago everything worked following the video of @Eldar but today I verify that strangely the galleries do not work anymore!

What happened again?

Blocs 2.5.2 • MacOS Sierra 10.12.6

1 Like

Hey, I will take a look at it today! Thanks for brining it to my attention!

1 Like

Everything works fine here on both of my machines!

Blocs 2.5.2 • MacOS Sierra 10.11.6

Blocs 2.5.2 • MacOS Sierra 10.13.4

Checked. The image gallery works correctly !

2.5.2 bloques • MacOS Sierra 10.13.3

reformas.redecor-elche.com

Okay thanks for the feedback people :slight_smile:

FYI: I created a new Blocs file this afternoon and was able to build a lightbox gallery using the same assets without any problem. However, I still can’t get the lightbox to work with my test site. So obviously the issue is with my Bloc file, and not the application. If I manage to fix the issue I’ll let you know.

Blocs 2.5.2 // macOS High Sierra 10.13.4

Same here, everything works fine with the latest version of Blocs. It is difficult to say what’s wrong with your file, without taking a look at it.

1 Like

I’ve now isolated what my issue with the Lightbox gallery is.

Using the test file I created yesterday, which has a Lightbox gallery that works as expected, I then added a new page with a basic structure Bric. I then added the Swiper bric to it, that I bought from @Lucas. When I previewed the site, the Lightbox gallery doesn’t function anymore. I then deleted the page with the Swiper bric on it, and the Lightbox gallery works again.

There is obviously some script conflict somewhere, between the Swiper bric and the Blocs app. I’d thought I’d share this information with others who maybe trying to use the same combination of features, so you are at least aware of this bug.

Blocs 2.5.2 // macOS High Sierra 10.13.4

3 Likes

Hi @DerekDigital I managed to spot the issue, Swiper it is indeed hiding the lighbox and may occur in other pages in that don’t include Swiper. I’ve already fixed the issue here and will upload a new version later today.

4 Likes

Yes @DerekDigital, I also tried to delete Swiper and everything is back to normal.

That’s great news @Lucas. Look forward to getting the update later.

Sooner or later, following Custom Bric will be available:

1 Like

Just a quick message to say that I did released the Swiper update yesterday, follow the instructions on the manual to update :wink:

1 Like

Thank-you @Lucas. Swiper and my Lightbox Gallery now both work perfectly!

1 Like