PulseCMS


#41

@pulsecms @Norm So I am looking a little closer at the code of the website I built. I didn’t catch this at first. The website code is all in the “title” tag, and not after the “body” tag, no wonder it is loading a blank page… there is no code there…

I’m going to log this as a “bug” report as well

Screenshot attached


#42

Hi @Raimo
I also have a little bit trouble…
I don’t know if that helps, but…
Do you have inside of blocks in the page settings a site description ?
If it is so leave the field blank and do the description later in the pulse dashboard. In your jpg I see there is no description… blocs or Pulse have problems with this. So leave the field empty and do an export. Go to your pulse site in the dashboard and insert a description and also click the button that you wish the site was“follow“ ( I also see that you have noindex; follow ) and than click save …
I don’t know if that helps … my problem were solved on this way …
All the best
Tom


#43

@tom2 Thanks, gave me an idea. Nothing I do on the Blocs 3 side seems to help, but if I go into the Pulse 5 side and open the pages one at a time, and move all the code from the “meta -> Page Title” and paste it into the proper place below, at least I can get the pages working


#44

Has anyone heard from Blocs on this or found a solution?


#45

I opened a bug report with @Norm and hopefully they can track down the issue. I love Pulse, and if we can get it working properly here, would gladly leave Rapidweaver behind…


#46

@Norm Okay, been playing with it, and at least I can get the test site to load now using @tom2 suggestions

  • make sure there is both a “Page Name” and “SEO Title” for every page in your Blocs 3 project

And in the Pulse 5 Project “export” settings

  • “unclick” Minify HTML
  • “unclick” Minify Main CSS
  • “unclick” Enable Lazy Loading

So at least the exported files now work with Pulse 5

I also figured out how to add Pulse compatible “Blocks” that can be nested in folders

  • don’t use the Blocs 3 “Pulse Bric”
  • instead use a “HTML Widget” and put in the regular Pulse tags for your blocks {{block:folder-name/block-name}} example {{block:home-page/main-content}} that way you can organize your editable areas into “folders” in the Pulse dashboard, makes finding them far easier… you will have to create the folder and editable area through the Pulse dashboard though
  • AND this seems like it will also embed whatever other Pulse tags you want. I tried it with a Pulse {{masonry:galname}} “tag” and inderneath it, a {{justforms}} “tag” (Pulse 5’s advanced form builder) on this test page

Now what still doesn’t work is the “on-screen editor”, no little pink boxes… Something else is still getting over-ridden when exporting the Pulse 5 project out of Blocs 3.

One other note - by using “Pulse Tags” inside of HTML Widgets instead of “Pulse Brics” - all content editing is done through the Pulse 5 Dashboard (and hopefully, if we can get it working, the “in-line editor” which is sweet for the clients!)

  • When you upload any page changes from Blocs to your Pulse install, you only need to upload the “Template” folder, and the “Pages” folder inside the “Content” folder. That way you never worry about wiping out any changes that were made by you, or your client.

I have posted this over on the Pulse CMS forums as well


#47

Hey folks our office re-opened yesterday after the holidays. I’m currently working my way through tickets and rolling all fixes into the Blocs V3.1.0 beta, which will be available early next week.

Sorry for the longer than normal delay on this one, and thank you for logging tickets as well as this discussion :+1:


#48

Has anyone already tested a Bric form with Pulse 5.2.2? Unfortunately, this does not work for me.


#49

@Raimo Thanks for the work and sharing your results. It would be really nice to have this solved.

casey


#50

Ok, the minify issue is caused specifically by the minify HTML option, all my tests with the other options have no effect but minify HTML does indeed break the template.

This is because Pulse requires the first two lines of the page template docs to be separate lines.

Blocs 3.1 (beta next week) now handles this so it wont be an issue going forward.

Thank you for taking the time to report and dig in to find the cause, it was a real time saver.

:pray: