Blocs V5.1 Beta Build 7 😅

Hey everyone, here is 7th beta of Blocs V5.1. This build has more bug fixes and a few little improvements to the AI Assistant.

Anyway have a great weekend and happy testing! :beers:

Download Blocs 5.1 Beta 7


Thank you! Have a great weekend!


Hi @Norm

When I installed the new beta version, it asked for the license key again, and the basic settings also returned to factory defaults.

I can’t choose light, dark, or no style either.

You can just manually create those if you need to.

1 Like

Yes, I know, I was just surprised that they disappeared, which were included by default.

1 Like

Not exactly sure why you lost those, maybe if you run blocs under a different account. They are not default by the way, those a minimalist libraries :sunglasses:

How can I do that? I can’t find it…

I updated an old website today using this beta and switched on the option for WebP images. I just noticed on the gallery that the thumbs are WebP, however the enlarged pop ups are Jpg files when dragged to the desktop, which I believe was also reported some time ago by others.

Looking at the project and the asset manager I can see that the thumb and enlargements are all using the same original Jpg files, but only the thumbs are being converted to WebP.

@Norm When will the 5.1 final release arrive?

I was just thinking about the same question.

1 Like

There were many betas from 5.1.

June, after ipad release


I am just trying the SMTP form option on a new website and the alert message said it was successfully sent, but after half an hour nothing has yet to appear and there is no sign in the spam folder, either locally or on the server. I am using port 465 rather than 587, because my ISP suggests 465 and that is what I use in my mail client. **Later tried 587 with the same result.

As a test I tried another web page that has a standard php form in place that was set up previously. The email came through after two minutes, however it had the wrong subject message that does not reflect the subject setting in Blocs. For some strange reason it has taken the subject from another very distant page.

It gets worse; the reply to address is no longer the address included by the sender. Instead it shows as

This is the first time I’ve ever had issues sending mail via contact forms in Blocs. It all seems a bit broken suddenly.

As a follow up I tried enabling outbound SMTP on my server, but nothing has changed and no emails are arriving. As mentioned before, it also seems that Blocs is randomly changing the email subjects on export, taking subject titles from other pages that are nothing like what I see inside Blocs for the related pages.

All of this is there in the includes php contact files. Now when an email arrives I have absolutely no idea now which pages were actually used, unless I am prepared to go sniffing through those includes files. Failing that I’ll have to manually edit them each time outside of Blocs.

In addition, the select editor, which was previously working fine is no longer indicating the selected option when on the standard php emails come through. The field is still there but the chosen selection is blank.

It’s very minor in comparison, but not even the alert class is adopting the right font for messages declared as being successfully sent.

I have concerns about updating any Blocs website with these issues.

Update I’ve just gone back to 5.0.8 and all the same issues are there with the php. This may well be after saving the project in the beta, so the bug carries over.

**As a further update I have just looked at the code structure in the contact.php includes file, comparing a new site against an older one and it is looking very different now. Whatever changes have been made seem to be very broken.

1 Like

I have spent hours looking at this today and on my servers at least SMTP is not working. I press the send button and it doesn’t trigger the alert message to say that an email has either been sent or failed. Nothing happens and nothing arrives.

I had another go with a simple new php contact form created using this beta and that seems to be working. Also checking the includes file appears to be fairly normal. It’s not the same format as it was on older sites, but appears to work nonetheless.

At some point it looks like the php forms went very wrong with all the errors mentioned above, so now I am struggling to pinpoint when this happened and which websites are potentially affected. To anybody reading this I would suggest you check your websites by sending a quick test email.

You could also look inside your exported includes files for any section that looks like this:

// Create email	
	$email_subject = "Website Enquiry";
	$email_body = "You have received a new message. \n\n".
				  "Name_33889: $name_33889 \nEmail_33889: $email_33889 \nNumber_33889: $number_33889 \nSelect_Service: $select_service \nMessage_33889: $message_33889 \nConsent_33889: $consent_33889 \n";
	$headers = "MIME-Version: 1.0\r\nContent-type: text/plain; charset=UTF-8\r\n";	
	$headers .= "From:\r\n";
	$headers .= "Reply-To:";	
	mail($to,$email_subject,$email_body,$headers); // Post message
	return true;			

I know many of us (myself included) are not code junkies, but if you see it’s a pretty surefire bet there is a problem.

On one particular large website I have something like 30 contact forms, due to various targeted landing pages. I can see from the various includes files that some are OK, while others have errors. In one case I copy pasted a bloc to several pages and every one shows as coming from the same page, even though I always changed the subject information, which is not reflected in the emails that arrive.

All in all it’s a bit of mess that needs some time to untangle.


Hope @Norm looks into why this is happening as I have a a string of websites coming up where forms are really important for their business.

SMTP forms is very dependent on server setup. If your hosting doesn’t work with them then use the classic forms.

The php forms are the bigger issue for me, suddenly discovering many are broken, while others are fine on the same website. This means having to check each one independently, then rebuild in various cases. Some forms have multiple options, so this is not a 5 minute job.

1 Like

Am I correct in thinking this is only a problem when you use SMTP forms with 5.1?

No the SMTP flat out doesn’t work, so I basically left it alone. All the other mentioned issues are php related with existing forms that were created. The exported code in some cases is all wrong like the example I posted earlier.

1 Like

Using Blocs 5.1 too early ?

Hi guys, I started a new Blocs projects with v5.1b7 using Eldar minimalist library.

1 hour, 2 crashes !
Of course I don’t save every 5 minutes so I had to start over.
Not only crashes but strange behavior. For instance, if I want to select a font when editing a class, I have to click multiple time to succeed selecting a font in the dropdown menu. It keep on closing as soon as my mouse reach the dropdown.

So my question above.